Press "Enter" to skip to content

PrestaShop 1.4 i błąd: mysql_connect(): The mysql extension is deprecated

Admin 0

Po zainstalowaniu sklepu na serwerze mamy następujący komunikat:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: 
use mysqli or PDO instead in /var/www/projekt/classes/MySQL.php on line 34

Oczywiście można przebudować connectory MySQL pod kątem niedozwolonych w PHP funkcji do łączenia z bazą (stąd ten błąd) ale można też zastosować rozwiązanie na szybko. Do czego oczywiście nie zachęcamy, bo to naraża sklep na względny atak w przyszłości.

Po prostu w pliku:

config/config.inc.php

dodajemy na początku wpis:

error_reporting(E_ALL ^ E_DEPRECATED);

 

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.

Zobacz także !
Podczas uploadu zdjęć na sklepie pojawia się enigmatyczny błąd o…